Read the docs
TI-2022-03948 Aliases CVE-2022-4310GHSA-r87w-g396-c68p

Slimstat Analytics < 4.9.3 - Unauthenticated Stored XSS

Priority MEDIUM 60Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Slimstat Analytics WordPress plugin before 4.9.3 does not sanitise and escape the URI when logging requests, which could allow unauthenticated attackers to perform Stored Cross-Site Scripting attacks against logged in admin viewing the logs

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00648 51st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Slimstat Analytics (Unknown): 4.9.3

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownSlimstat Analyticsbefore 4.9.34.9.3Patch availableCNA
  • Slimstat Analytics VendorUnknown Affected before 4.9.3 Fixed in 4.9.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wp-slimstat:slimstat_analytics:*:*:*:*:*:wordpress:*:*before 4.9.3VulnerableJason Crouse, VeronaLabs
  • cpe:2.3:a:wp-slimstat:slimstat_analytics:*:*:*:*:*:wordpress:*:* Versions before 4.9.3 Vulnerable ·Jason Crouse, VeronaLabs

Remediation

  • Fix · CNA Slimstat Analytics (Unknown) Fixed in 4.9.3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4310
  2. 2026-10-03 Alias added: GHSA-r87w-g396-c68p
  3. 2026-10-20 EPSS moved to the 50th–90th percentile

References

  • TI-2023-00597 Slimstat Analytics < 4.9.3.3 - Subscriber+ SQL Injection CVSS 3.1HIGH 8.8
  • TI-2022-22339 WordPress Slimstat Analytics Plugin <= 5.0.4 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2023-04242 Slimstat Analytics <= 5.0.9 - Authenticated (Contributor+) Blind SQL Injection via Shortcode CVSS 3.1HIGH 8.8
  • TI-2024-08857 Slimstat Analytics <= 5.2.6 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
  • TI-2022-22332 WordPress Slimstat Analytics Plugin <= 5.0.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2023-04241 Slimstat Analytics <= 5.0.9 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
See all 10 →

Sources