WordPress Events Calendar Plugin < 1.4.5 - Multiple Reflected XSS
Priority MEDIUM 60Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WordPress Events Calendar WordPress plugin before 1.4.5 does not sanitize and escapes a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against both unauthenticated and authenticated users (such as high-privilege ones like admin).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.009 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WordPress Events Calendar Plugin (Unknown): 1.4.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Events Calendar Plugin | before 1.4.5 | 1.4.5 | Patch available | CNA |
- WordPress Events Calendar Plugin VendorUnknown Affected before 1.4.5 Fixed in 1.4.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mhsoftware:wordpress_events_calendar_plugin:*:*:*:*:*:wordpress:*:* | before 1.4.5 | Vulnerable | Mhsoftware |
- cpe:2.3:a:mhsoftware:wordpress_events_calendar_plugin:*:*:*:*:*:wordpress:*:* Versions before 1.4.5 Vulnerable ·Mhsoftware
Remediation
- Fix · CNA WordPress Events Calendar Plugin (Unknown) Fixed in 1.4.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4320
- 2026-10-03 Alias added: GHSA-7r7m-9r2x-mccm
References
Sources
- CVE-2022-4320 · CVE Program
- CVE-2022-4320 · NVD
- FIRST EPSS
- GHSA-7r7m-9r2x-mccm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences