Mautic Integration For WooCommerce < 1.0.3 - Arbitrary Options Update via CSRF
Priority MEDIUM 53Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Mautic Integration for WooCommerce WordPress plugin before 1.0.3 does not have proper CSRF check when updating settings, and does not ensure that the options to be updated belong to the plugin, allowing attackers to make a logged in admin change arbitrary blog options via a CSRF attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00311 24th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Mautic Integration for WooCommerce (Unknown): 1.0.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Mautic Integration for WooCommerce | before 1.0.3 | 1.0.3 | Patch available | CNA |
- Mautic Integration for WooCommerce VendorUnknown Affected before 1.0.3 Fixed in 1.0.3 Patch available CNA
Remediation
- Fix · CNA Mautic Integration for WooCommerce (Unknown) Fixed in 1.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4426
- 2026-10-03 Alias added: GHSA-c2gf-h728-j378
References
Sources
- CVE-2022-4426 · CVE Program
- CVE-2022-4426 · NVD
- FIRST EPSS
- GHSA-c2gf-h728-j378 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences