Simple Membership < 4.2.2 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Simple Membership WordPress plugin before 4.2.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00539 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Simple Membership (Unknown): 4.2.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Simple Membership | before 4.2.2 | 4.2.2 | Patch available | CNA |
- Simple Membership VendorUnknown Affected before 4.2.2 Fixed in 4.2.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simple-membership-plugin:simple_membership:*:*:*:*:*:wordpress:*:* | before 4.2.2 | Vulnerable | wpinsider-1 |
- cpe:2.3:a:simple-membership-plugin:simple_membership:*:*:*:*:*:wordpress:*:* Versions before 4.2.2 Vulnerable ·wpinsider-1
Remediation
- Fix · CNA Simple Membership (Unknown) Fixed in 4.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4469
- 2026-10-03 Alias added: GHSA-2j6x-6qc7-3mw5
References
More wpinsider-1 Simple Membership vulnerabilities
- TI-2023-22342 WordPress Simple Membership plugin <= 4.3.4 - Unauthenticated Membership Role Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2022-02140 Simple Membership < 4.1.3 - Unauthenticated Membership Privilege Escalation CVSS 3.1CRITICAL 9.8
- TI-2019-10675 The Simple Membership plugin before 3.8.5 for WordPress has CSRF affecting the Bulk Operation section. CVSS 3.0HIGH 8.8
- TI-2023-22341 WordPress Simple Membership plugin <= 4.3.4 - Authenticated Account Takeover vulnerability CVSS 3.1HIGH 8.8
- TI-2024-10273 Simple Membership <= 4.5.5 - Exposure of Private Personal Information to an Unauthorized Actor CVSS 3.1HIGH 7.5
- TI-2022-02098 Simple Membership < 4.1.3 - Membership Privilege Escalation CVSS 3.1HIGH 8.8
Sources
- CVE-2022-4469 · CVE Program
- CVE-2022-4469 · NVD
- FIRST EPSS
- GHSA-2j6x-6qc7-3mw5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences