Collapse-O-Matic < 1.8.3 - Contributor+ Stored XSS
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Collapse-O-Matic WordPress plugin before 1.8.3 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00539 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Collapse-O-Matic (Unknown): 1.8.3
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Collapse-O-Matic | before 1.8.3 | 1.8.3 | Patch available | CNA |
- Collapse-O-Matic VendorUnknown Affected before 1.8.3 Fixed in 1.8.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:twinpictures:collapse-o-matic:*:*:*:*:*:wordpress:*:* | before 1.8.3 | Vulnerable | Twinpictures |
- cpe:2.3:a:twinpictures:collapse-o-matic:*:*:*:*:*:wordpress:*:* Versions before 1.8.3 Vulnerable ·Twinpictures
Remediation
- Fix · CNA Collapse-O-Matic (Unknown) Fixed in 1.8.3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4475
- 2026-10-03 Alias added: GHSA-7fx8-7jc6-6whx
References
More Twinpictures Collapse-o-matic vulnerabilities
- TI-2023-21461 WordPress Collapse-O-Matic Plugin <= 1.8.5.5 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-4475 · CVE Program
- CVE-2022-4475 · NVD
- FIRST EPSS
- GHSA-7fx8-7jc6-6whx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences