Click to Chat < 3.18.1 - Contributor+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Click to Chat WordPress plugin before 3.18.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Click to Chat | before 3.18.1 | 3.18.1 | Patch available | CNA |
- Click to Chat VendorUnknown Affected before 3.18.1 Fixed in 3.18.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:holithemes:click_to_chat:*:*:*:*:*:wordpress:*:* | before 3.18.1 | Vulnerable | holithemes |
- cpe:2.3:a:holithemes:click_to_chat:*:*:*:*:*:wordpress:*:* Versions before 3.18.1 Vulnerable ·holithemes
Remediation
- Fix · CNA Click to Chat (Unknown) Fixed in 3.18.1
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4480
- 2026-10-03 Alias added: GHSA-9xj4-5v95-cwmv
References
Sources
- CVE-2022-4480 · CVE Program
- CVE-2022-4480 · NVD
- FIRST EPSS
- GHSA-9xj4-5v95-cwmv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences