WOOF - Products Filter for WooCommerce < 1.3.2 - Admin+ PHP Object Injection
Priority HIGH 67Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The HUSKY WordPress plugin before 1.3.2 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01313 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed HUSKY (Unknown): 1.3.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | HUSKY | before 1.3.2 | 1.3.2 | Patch available | CNA |
- HUSKY VendorUnknown Affected before 1.3.2 Fixed in 1.3.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pluginus:husky_-_products_filter_professional_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 1.3.2 | Vulnerable | realmag777 |
- cpe:2.3:a:pluginus:husky_-_products_filter_professional_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 1.3.2 Vulnerable ·realmag777
Remediation
- Fix · CNA HUSKY (Unknown) Fixed in 1.3.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4489
- 2026-10-03 Alias added: GHSA-jhhr-q29j-x5hq
References
More realmag777 Husky - Products Filter Professional For Woocommerce vulnerabilities
- TI-2025-01427 HUSKY – Products Filter Professional for WooCommerce <= 1.3.6.5 - Unauthenticated Local File Inclusion CVSS 3.1CRITICAL 9.8
- TI-2024-05993 HUSKY - Products Filter Professional for WooCommerce <= 1.3.6 - Unauthenticated Time-Based SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-20901 WordPress HUSKY – Products Filter for WooCommerce (formerly WOOF) Plugin <= 1.3.4.2 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2024-21560 WordPress HUSKY plugin <= 1.3.5.2 - Remote Code Execution (RCE) vulnerability CVSS 3.1HIGH 8.8
- TI-2024-28792 WordPress HUSKY plugin <= 1.3.6.1 - Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.1
- TI-2024-01671 HUSKY – Products Filter for WooCommerce Professional <= 1.3.5.2 - Authenticated (Contributor+) SQL Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2022-4489 · CVE Program
- CVE-2022-4489 · NVD
- FIRST EPSS
- GHSA-jhhr-q29j-x5hq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences