collective.dms.basecontent column.py renderCell cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability, which was classified as problematic, has been found in collective.dms.basecontent up to 1.6. This issue affects the function renderCell of the file src/collective/dms/basecontent/browser/column.py. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.7 is able to address this issue. The name of the patch is 6c4d616fcc771822a14ebae5e23f3f6d96d134bd. It is recommended to upgrade the affected component. The identifier VDB-215813 was assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | collective.dms.basecontent | 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6 | — | No fix listed | CNA |
| — | collective.dms.basecontent (PyPI) | before 1.7 | 1.7 | Patch available | GHSA-r48c-4vfj-h426 |
- collective.dms.basecontent Vendor— Affected 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6 Fixed in — No fix listed CNA
- collective.dms.basecontent (PyPI) Vendor— Affected before 1.7 Fixed in 1.7 Patch available GHSA-r48c-4vfj-h426
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:collective.dms.basecontent_project:collective.dms.basecontent:*:*:*:*:*:*:*:* | before 1.7 | Vulnerable | Collective.dms.basecontent Project |
- cpe:2.3:a:collective.dms.basecontent_project:collective.dms.basecontent:*:*:*:*:*:*:*:* Versions before 1.7 Vulnerable ·Collective.dms.basecontent Project
Remediation
- Fix · GHSA-r48c-4vfj-h426 collective.dms.basecontent (PyPI) Fixed in 1.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4495
- 2026-10-03 Alias added: GHSA-r48c-4vfj-h426
References
Sources
- CVE-2022-4495 · CVE Program
- CVE-2022-4495 · NVD
- FIRST EPSS
- GHSA-r48c-4vfj-h426 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences