WSO2 carbon-registry Request Parameter cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability classified as problematic has been found in WSO2 carbon-registry up to 4.8.6. This affects an unknown part of the component Request Parameter Handler. The manipulation of the argument parentPath/path/username/path/profile_menu leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 4.8.7 is able to address this issue. The name of the patch is 9f967abfde9317bee2cda469dbc09b57d539f2cc. It is recommended to upgrade the affected component. The identifier VDB-215901 was assigned to this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| WSO2 | carbon-registry | 4.8.0; 4.8.1; 4.8.2; 4.8.3; 4.8.4; 4.8.5; 4.8.6 | — | No fix listed | CNA |
| — | org.wso2.carbon.registry:carbon-registry (Maven) | before 4.8.7 | 4.8.7 | Patch available | GHSA-gp5f-gqgq-7254 |
- carbon-registry VendorWSO2 Affected 4.8.0; 4.8.1; 4.8.2; 4.8.3; 4.8.4; 4.8.5; 4.8.6 Fixed in — No fix listed CNA
- org.wso2.carbon.registry:carbon-registry (Maven) Vendor— Affected before 4.8.7 Fixed in 4.8.7 Patch available GHSA-gp5f-gqgq-7254
Remediation
- Fix · GHSA-gp5f-gqgq-7254 org.wso2.carbon.registry:carbon-registry (Maven) Fixed in 4.8.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4521
- 2026-10-03 Alias added: GHSA-gp5f-gqgq-7254
References
Patch 2
Advisory 2
More WSO2 Carbon-registry vulnerabilities
- TI-2022-04130 WSO2 carbon-registry Advanced Search advancedSearchForm-ajaxprocessor.jsp cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-4521 · CVE Program
- CVE-2022-4521 · NVD
- FIRST EPSS
- GHSA-gp5f-gqgq-7254 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences