Roots soil Plugin CleanUpModule.php language_attributes cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability, which was classified as problematic, was found in Roots soil Plugin up to 4.0.x. Affected is the function language_attributes of the file src/Modules/CleanUpModule.php. The manipulation of the argument language leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.1.0 is able to address this issue. The name of the patch is 0c9151e00ab047da253e5cdbfccb204dd423269d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215904.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Roots | soil Plugin | 4.0 | — | No fix listed | CNA |
| — | roots/soil (Packagist) | before 4.1.0 | 4.1.0 | Patch available | GHSA-jw6x-4h8h-569x |
- soil Plugin VendorRoots Affected 4.0 Fixed in — No fix listed CNA
- roots/soil (Packagist) Vendor— Affected before 4.1.0 Fixed in 4.1.0 Patch available GHSA-jw6x-4h8h-569x
Remediation
- Fix · GHSA-jw6x-4h8h-569x roots/soil (Packagist) Fixed in 4.1.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4524
- 2026-10-03 Alias added: GHSA-jw6x-4h8h-569x
References
Patch 2
Sources
- CVE-2022-4524 · CVE Program
- CVE-2022-4524 · NVD
- FIRST EPSS
- GHSA-jw6x-4h8h-569x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences