Alinto SOGo Identity SOGoUserDefaults.m _migrateMailIdentities cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability was found in Alinto SOGo up to 5.7.1 and classified as problematic. Affected by this issue is the function _migrateMailIdentities of the file SoObjects/SOGo/SOGoUserDefaults.m of the component Identity Handler. The manipulation of the argument fullName leads to cross site scripting. The attack may be launched remotely. Upgrading to version 5.8.0 is able to address this issue. The name of the patch is efac49ae91a4a325df9931e78e543f707a0f8e5e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-215960.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4556
- 2026-10-03 Alias added: GHSA-vxr5-ghr8-4787
References
More Alinto Sogo vulnerabilities
- TI-2025-39345 Alinto Sogo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the theme parameter. CVSS 3.1MEDIUM 6.1
- TI-2025-39344 alinto SOGo 5.12.3 is vulnerable to Cross Site Scripting (XSS) via the "userName" parameter. CVSS 3.1MEDIUM 6.1
- TI-2026-02638 Alinto SOGo cross site scripting CVSS 4.0MEDIUM 5.3
- TI-2015-04539 Cross-site request forgery (CSRF) vulnerability in SOGo before 3.1.0. CVSS 3.1HIGH 8.8
- TI-2016-05311 Memory leak in SOGo 2.3.7 allows remote attackers to cause a denial of service (memory… CVSS 3.1MEDIUM 6.5
- TI-2016-05314 Multiple cross-site scripting (XSS) vulnerabilities in the View Raw Source page in the… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-4556 · CVE Program
- CVE-2022-4556 · NVD
- FIRST EPSS
- GHSA-vxr5-ghr8-4787 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences