starter-public-edition-4 cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A vulnerability was found in starter-public-edition-4 up to 4.6.10. It has been classified as problematic. Affected is an unknown function. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 4.6.11 is able to address this issue. The name of the patch is 2606983c20f6ea3430ac4b36b3d2e88aafef45da. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216168.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | starter-public-edition-4 | 4.6.0; 4.6.1; 4.6.2; 4.6.3; 4.6.4; 4.6.5; 4.6.6; 4.6.7; 4.6.8; 4.6.9; 4.6.10 | — | No fix listed | CNA |
- starter-public-edition-4 Vendorunspecified Affected 4.6.0; 4.6.1; 4.6.2; 4.6.3; 4.6.4; 4.6.5; 4.6.6; 4.6.7; 4.6.8; 4.6.9; 4.6.10 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:starter-public-edition-4_project:starter-public-edition-4:*:*:*:*:*:*:*:* | before 4.6.11 | Vulnerable | Starter-public-edition-4 Project |
- cpe:2.3:a:starter-public-edition-4_project:starter-public-edition-4:*:*:*:*:*:*:*:* Versions before 4.6.11 Vulnerable ·Starter-public-edition-4 Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4582
- 2026-10-03 Alias added: GHSA-xxg6-wvf8-73xv
References
Sources
- CVE-2022-4582 · CVE Program
- CVE-2022-4582 · NVD
- FIRST EPSS
- GHSA-xxg6-wvf8-73xv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences