collective.contact.widget widgets.py title cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. This vulnerability affects the function title of the file src/collective/contact/widget/widgets.py. The manipulation leads to cross site scripting. The attack can be initiated remotely. The name of the patch is 5da36305ca7ed433782be8901c47387406fcda12. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216496.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| unspecified | collective.contact.widget | 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6; 1.7; 1.8; 1.9; 1.10; 1.11; 1.12 | — | No fix listed | CNA |
| — | collective.contact.widget (PyPI) | before 1.13 | 1.13 | Patch available | GHSA-5pqf-rvm7-3wgw |
- collective.contact.widget Vendorunspecified Affected 1.0; 1.1; 1.2; 1.3; 1.4; 1.5; 1.6; 1.7; 1.8; 1.9; 1.10; 1.11; 1.12 Fixed in — No fix listed CNA
- collective.contact.widget (PyPI) Vendor— Affected before 1.13 Fixed in 1.13 Patch available GHSA-5pqf-rvm7-3wgw
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:collective.contact.widget_project:collective.contact.widget:*:*:*:*:*:*:*:* | before 1.12 | Vulnerable | Collective.contact.widget Project |
- cpe:2.3:a:collective.contact.widget_project:collective.contact.widget:*:*:*:*:*:*:*:* Versions before 1.12 Vulnerable ·Collective.contact.widget Project
Remediation
- Fix · GHSA-5pqf-rvm7-3wgw collective.contact.widget (PyPI) Fixed in 1.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4638
- 2026-10-03 Alias added: GHSA-5pqf-rvm7-3wgw
References
Sources
- CVE-2022-4638 · CVE Program
- CVE-2022-4638 · NVD
- FIRST EPSS
- GHSA-5pqf-rvm7-3wgw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences