HashBar – WordPress Notification Bar < 1.3.6 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The HashBar WordPress plugin before 1.3.6 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00539 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed HashBar (Unknown): 1.3.6
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | HashBar | before 1.3.6 | 1.3.6 | Patch available | CNA |
- HashBar VendorUnknown Affected before 1.3.6 Fixed in 1.3.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hasthemes:hashbar:*:*:*:*:*:wordpress:*:* | before 1.3.6 | Vulnerable | devitemsllc |
- cpe:2.3:a:hasthemes:hashbar:*:*:*:*:*:wordpress:*:* Versions before 1.3.6 Vulnerable ·devitemsllc
Remediation
- Fix · CNA HashBar (Unknown) Fixed in 1.3.6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4650
- 2026-10-03 Alias added: GHSA-5645-4fvm-2wfj
References
More devitemsllc Hashbar vulnerabilities
- TI-2023-28030 WordPress HashBar – WordPress Notification Bar Plugin <= 1.4.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-4650 · CVE Program
- CVE-2022-4650 · NVD
- FIRST EPSS
- GHSA-5645-4fvm-2wfj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences