Woo Products Widgets For Elementor < 1.0.8 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Widgets for WooCommerce Products on Elementor WordPress plugin before 1.0.8 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Widgets for WooCommerce Products on Elementor (Unknown): 1.0.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Widgets for WooCommerce Products on Elementor | before 1.0.8 | 1.0.8 | Patch available | CNA |
- Widgets for WooCommerce Products on Elementor VendorUnknown Affected before 1.0.8 Fixed in 1.0.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:themelocation:widgets_for_woocommerce_products_on_elementor:*:*:*:*:*:wordpress:*:* | before 1.0.8 | Vulnerable | themelocation |
- cpe:2.3:a:themelocation:widgets_for_woocommerce_products_on_elementor:*:*:*:*:*:wordpress:*:* Versions before 1.0.8 Vulnerable ·themelocation
Remediation
- Fix · CNA Widgets for WooCommerce Products on Elementor (Unknown) Fixed in 1.0.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4661
- 2026-10-03 Alias added: GHSA-f2q5-2xf5-mxrw
References
Sources
- CVE-2022-4661 · CVE Program
- CVE-2022-4661 · NVD
- FIRST EPSS
- GHSA-f2q5-2xf5-mxrw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences