Easy Appointments < 3.11.2 - Contributor+ Stored XSS in Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Easy Appointments WordPress plugin before 3.11.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Easy Appointments (Unknown): 3.11.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Easy Appointments | before 3.11.2 | 3.11.2 | Patch available | CNA |
- Easy Appointments VendorUnknown Affected before 3.11.2 Fixed in 3.11.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:easy-appointments:easy_appointments:*:*:*:*:*:wordpress:*:* | before 3.11.2 | Vulnerable | Easy Appointments |
- cpe:2.3:a:easy-appointments:easy_appointments:*:*:*:*:*:wordpress:*:* Versions before 3.11.2 Vulnerable ·Easy Appointments
Remediation
- Fix · CNA Easy Appointments (Unknown) Fixed in 3.11.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4668
- 2026-10-03 Alias added: GHSA-2xhc-425v-mmxp
References
More Easy Appointments vulnerabilities
- TI-2022-16753 WordPress Easy Appointments Plugin <= 3.11.9 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-02652 Easy Appointments <= 3.11.18 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2017-11567 The Easy Appointments plugin before 1.12.0 for WordPress has XSS via a Settings values in the admin panel. CVSS 3.0MEDIUM 6.1
- TI-2023-14562 WordPress Easy Appointments plugin <= 3.10.7 - Auth. Stored Cross-Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.1
- TI-2024-02654 Easy Appointments <= 3.11.18 - Insufficient Authorization CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-4668 · CVE Program
- CVE-2022-4668 · NVD
- FIRST EPSS
- GHSA-2xhc-425v-mmxp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences