Read the docs
TI-2022-04267 Aliases CVE-2022-4669GHSA-4mw6-hf2w-jx7x

Page Builder: Live Composer < 1.5.23 - Contributor+ Stored XSS via Shortcode

Priority MEDIUM 58CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Page Builder: Live Composer WordPress plugin before 1.5.23 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00393 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Page Builder: Live Composer (Unknown): 1.5.23

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPage Builder: Live Composerbefore 1.5.231.5.23Patch availableCNA
  • Page Builder: Live Composer VendorUnknown Affected before 1.5.23 Fixed in 1.5.23 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:blueastral:page_builder\:_live_composer:*:*:*:*:*:wordpress:*:*_live_composerVulnerableLive Composer Team
  • cpe:2.3:a:blueastral:page_builder\:_live_composer:*:*:*:*:*:wordpress:*:* Versions _live_composer Vulnerable ·Live Composer Team

Remediation

  • Fix · CNA Page Builder: Live Composer (Unknown) Fixed in 1.5.23

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4669
  2. 2026-10-03 Alias added: GHSA-4mw6-hf2w-jx7x

References

  • TI-2023-28634 WordPress Page Builder: Live Composer Plugin <= 1.5.25 is vulnerable to PHP Object Injection CVSS 3.1HIGH 7.7
  • TI-2024-23648 WordPress Page Builder: Live Composer plugin <= 1.5.42 - Contributor+ Shortcode Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2023-28621 WordPress Page Builder: Live Composer Plugin <= 1.5.23 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2024-23637 WordPress Page Builder: Live Composer plugin <= 2.1.22 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 5.9

Sources