PDF.js Viewer < 2.1.8 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The PDF.js Viewer WordPress plugin before 2.1.8 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00562 46th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed PDF.js Viewer (Unknown): 2.1.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | PDF.js Viewer | before 2.1.8 | 2.1.8 | Patch available | CNA |
- PDF.js Viewer VendorUnknown Affected before 2.1.8 Fixed in 2.1.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pdf.js_viewer_project:pdf.js_viewer:*:*:*:*:*:wordpress:*:* | before 2.1.8 | Vulnerable | Pdf.js Viewer Project |
- cpe:2.3:a:pdf.js_viewer_project:pdf.js_viewer:*:*:*:*:*:wordpress:*:* Versions before 2.1.8 Vulnerable ·Pdf.js Viewer Project
Remediation
- Fix · CNA PDF.js Viewer (Unknown) Fixed in 2.1.8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4670
- 2026-10-03 Alias added: GHSA-prq5-cfmm-gwc2
References
More Pdf.js Viewer Project Pdf.js Viewer vulnerabilities
- TI-2021-07041 PDF.js Viewer < 2.0.2 - Contributor+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-4670 · CVE Program
- CVE-2022-4670 · NVD
- FIRST EPSS
- GHSA-prq5-cfmm-gwc2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences