WordPress Simple Shopping Cart < 4.6.2 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WordPress Simple Shopping Cart WordPress plugin before 4.6.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00539 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WordPress Simple Shopping Cart (Unknown): 4.6.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WordPress Simple Shopping Cart | before 4.6.2 | 4.6.2 | Patch available | CNA |
- WordPress Simple Shopping Cart VendorUnknown Affected before 4.6.2 Fixed in 4.6.2 Patch available CNA
Remediation
- Fix · CNA WordPress Simple Shopping Cart (Unknown) Fixed in 4.6.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4672
- 2026-10-03 Alias added: GHSA-jx46-9ppx-mm7j
References
More mra13 Wordpress Simple Paypal Shopping Cart vulnerabilities
- TI-2025-03422 WordPress Simple PayPal Shopping Cart <= 5.1.3 - Insecure Direct Object Reference CVSS 3.1MEDIUM 6.5
- TI-2013-02366 Cross-site request forgery (CSRF) vulnerability in the WordPress Simple Paypal Shopping… CVSS 2.0MEDIUM 6.8
- TI-2023-01352 The WP Simple Shopping Cart plugin for WordPress is vulnerable to Sensitive Information… CVSS 3.1MEDIUM 5.3
- TI-2025-03436 WordPress Simple PayPal Shopping Cart <= 5.1.3 - Insecure Direct Object Reference via 'quantity' CVSS 3.1MEDIUM 5.3
- TI-2025-03437 WordPress Simple PayPal Shopping Cart <= 5.1.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
- TI-2023-05954 WordPress Simple Shopping Cart <= 4.7.1 - Authenticated(Administrator+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-4672 · CVE Program
- CVE-2022-4672 · NVD
- FIRST EPSS
- GHSA-jx46-9ppx-mm7j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences