Read the docs
TI-2022-04271 Aliases CVE-2022-4673GHSA-6x9q-3f3x-4w22

Rate my Post – WP Rating System < 3.3.9 - Contributor+ Stored XSS via Shortcode

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Rate my Post WordPress plugin before 3.3.9 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Rate my Post (Unknown): 3.3.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownRate my Postbefore 3.3.93.3.9Patch availableCNA
  • Rate my Post VendorUnknown Affected before 3.3.9 Fixed in 3.3.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:blazzdev:rate_my_post:*:*:*:*:*:wordpress:*:*before 3.3.9VulnerableBlaz K.
  • cpe:2.3:a:blazzdev:rate_my_post:*:*:*:*:*:wordpress:*:* Versions before 3.3.9 Vulnerable ·Blaz K.

Remediation

  • Fix · CNA Rate my Post (Unknown) Fixed in 3.3.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4673
  2. 2026-10-03 Alias added: GHSA-6x9q-3f3x-4w22

References

  • TI-2023-28314 WordPress Rate my Post – WP Rating System plugin <= 3.4.2 - Broken Access Control vulnerability CVSS 3.1HIGH 8.2
  • TI-2023-27175 WordPress Rate my Post – WP Rating System Plugin <= 3.4.1 is vulnerable to Insecure Direct Object References (IDOR) CVSS 3.1MEDIUM 6.5
  • TI-2024-21697 WordPress Rate My Post plugin <= 3.4.4 - Insecure Direct Object References (IDOR) vulnerability CVSS 3.1MEDIUM 5.3

Sources