Mongoose Page Plugin < 1.9.0 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Mongoose Page Plugin WordPress plugin before 1.9.0 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Mongoose Page Plugin (Unknown): 1.9.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Mongoose Page Plugin | before 1.9.0 | 1.9.0 | Patch available | CNA |
- Mongoose Page Plugin VendorUnknown Affected before 1.9.0 Fixed in 1.9.0 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mongoosemarketplace:mongoose_page_plugin:*:*:*:*:*:wordpress:*:* | before 1.9.0 | Vulnerable | Mongoosemarketplace |
- cpe:2.3:a:mongoosemarketplace:mongoose_page_plugin:*:*:*:*:*:wordpress:*:* Versions before 1.9.0 Vulnerable ·Mongoosemarketplace
Remediation
- Fix · CNA Mongoose Page Plugin (Unknown) Fixed in 1.9.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4675
- 2026-10-03 Alias added: GHSA-g2qg-fxj7-jg27
References
Sources
- CVE-2022-4675 · CVE Program
- CVE-2022-4675 · NVD
- FIRST EPSS
- GHSA-g2qg-fxj7-jg27 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences