Read the docs
TI-2022-04279 Aliases CVE-2022-4681GHSA-6vgw-7v97-h3ch

Hide My WP < 6.2.9 - Unauthenticated SQLi

Priority HIGH 82Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Hide My WP WordPress plugin before 6.2.9 does not properly sanitize and escape a parameter before using it in a SQL statement via an AJAX action available to unauthenticated users, leading to a SQL injection.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.03824 90th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Hide My WP (Unknown): 6.2.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownHide My WPbefore 6.2.96.2.9Patch availableCNA
  • Hide My WP VendorUnknown Affected before 6.2.9 Fixed in 6.2.9 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpwave:hide_my_wp:*:*:*:*:*:wordpress:*:*before 6.2.9VulnerablewpWave
  • cpe:2.3:a:wpwave:hide_my_wp:*:*:*:*:*:wordpress:*:* Versions before 6.2.9 Vulnerable ·wpWave

Remediation

  • Fix · CNA Hide My WP (Unknown) Fixed in 6.2.9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4681
  2. 2026-10-03 Alias added: GHSA-6vgw-7v97-h3ch
  3. 2026-10-21 EPSS moved to the 90th–95th percentile
  4. 2026-10-25 EPSS moved to the 50th–90th percentile
  5. 2026-10-27 EPSS moved to the 90th–95th percentile

References

  • TI-2021-14997 WordPress Hide My WP premium plugin <= 6.2.3 - Unauthenticated SQL injection (SQLi) vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2021-14998 WordPress Hide My WP premium plugin <= 6.2.3 - Unauthenticated Plugin Deactivation vulnerability CVSS 3.1HIGH 7.5

Sources