Read the docs
TI-2022-04311 Aliases CVE-2022-4715GHSA-r953-7653-mvj6

Structured Content < 1.5.1 - Contributor+ Stored XSS in Shortcode

Priority HIGH 66Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Structured Content WordPress plugin before 1.5.1 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Structured Content (JSON-LD) #wpsc (Unknown): 1.5.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownStructured Content (JSON-LD) #wpscbefore 1.5.11.5.1Patch availableCNA
  • Structured Content (JSON-LD) #wpsc VendorUnknown Affected before 1.5.1 Fixed in 1.5.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wpsc-plugin:structured_content:*:*:*:*:*:wordpress:*:*before 1.5.1VulnerableGordon Böhme, Antonio Leutsch

Remediation

  • Fix · CNA Structured Content (JSON-LD) #wpsc (Unknown) Fixed in 1.5.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4715
  2. 2026-10-03 Alias added: GHSA-r953-7653-mvj6

References

  • TI-2023-27223 WordPress Structured Content Plugin <= 1.5.3 is vulnerable to PHP Object Injection CVSS 3.1CRITICAL 9.8
  • TI-2024-16356 WordPress Structured Content Plugin <= 1.6.1 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2023-27224 WordPress Structured Content Plugin <= 1.5.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2025-00426 Cross-site scripting in gorbo Structured Content #wpsc CVSS 3.1MEDIUM 6.4

Sources