10WebMapBuilder < 1.0.72 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The 10WebMapBuilder WordPress plugin before 1.0.72 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed 10WebMapBuilder (Unknown): 1.0.72
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | 10WebMapBuilder | before 1.0.72 | 1.0.72 | Patch available | CNA |
- 10WebMapBuilder VendorUnknown Affected before 1.0.72 Fixed in 1.0.72 Patch available CNA
Remediation
- Fix · CNA 10WebMapBuilder (Unknown) Fixed in 1.0.72
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4758
- 2026-10-03 Alias added: GHSA-mmm6-292h-j64g
References
More 10web Map Builder For Google Maps vulnerabilities
- TI-2023-00035 10WebMapBuilder < 1.0.73 - Unauthenticated SQLi CVSS 3.1CRITICAL 9.8
- TI-2024-20505 WordPress 10Web Map Builder for Google Maps plugin <= 1.0.74 - SQL Injection vulnerability CVSS 3.1HIGH 7.6
- TI-2023-24262 WordPress 10Web Map Builder for Google Maps plugin <= 1.0.73 - Notice Dismissal Vulnerability CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-4758 · CVE Program
- CVE-2022-4758 · NVD
- FIRST EPSS
- GHSA-mmm6-292h-j64g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences