GigPress < 2.3.28 - Contributor+ Stored XSS via Shortcode
Priority HIGH 65Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The GigPress WordPress plugin before 2.3.28 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00707 53rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed GigPress (Unknown): 2.3.28
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | GigPress | before 2.3.28 | 2.3.28 | Patch available | CNA |
- GigPress VendorUnknown Affected before 2.3.28 Fixed in 2.3.28 Patch available CNA
Remediation
- Fix · CNA GigPress (Unknown) Fixed in 2.3.28
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4759
- 2026-10-03 Alias added: GHSA-rr77-8cxr-6h8g
References
More Tri Gigpress vulnerabilities
- TI-2023-00365 GigPress <= 2.3.28 - Subscriber+ SQLi CVSS 3.1HIGH 8.8
- TI-2023-06617 GigPress <= 2.3.29 - Admin+ Stored Cross Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2015-03427 Multiple SQL injection vulnerabilities in admin/handlers.php in the GigPress plugin… CVSS 2.0MEDIUM 6.5
- TI-2015-07730 The gigpress plugin before 2.3.11 for WordPress has SQL injection in the admin area, a… CVSS 3.1HIGH 7.2
- TI-2015-07731 The gigpress plugin before 2.3.11 for WordPress has XSS. CVSS 3.1MEDIUM 4.8
Sources
- CVE-2022-4759 · CVE Program
- CVE-2022-4759 · NVD
- FIRST EPSS
- GHSA-rr77-8cxr-6h8g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences