Icon Widget < 1.3.0 - Contributor+ Stored XSS via Shortcode
Priority LOW 25Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Icon Widget WordPress plugin before 1.3.0 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Icon Widget (Unknown): 1.3.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Icon Widget | before 1.3.0 | 1.3.0 | Patch available | CNA |
- Icon Widget VendorUnknown Affected before 1.3.0 Fixed in 1.3.0 Patch available CNA
Remediation
- Fix · CNA Icon Widget (Unknown) Fixed in 1.3.0
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4763
- 2026-10-03 Alias added: GHSA-pf73-wv46-5h3f
References
Sources
- CVE-2022-4763 · CVE Program
- CVE-2022-4763 · NVD
- FIRST EPSS
- GHSA-pf73-wv46-5h3f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences