WPZOOM Portfolio < 1.2.2 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The WPZOOM Portfolio WordPress plugin before 1.2.2 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00476 41st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WPZOOM Portfolio (Unknown): 1.2.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WPZOOM Portfolio | before 1.2.2 | 1.2.2 | Patch available | CNA |
- WPZOOM Portfolio VendorUnknown Affected before 1.2.2 Fixed in 1.2.2 Patch available CNA
Remediation
- Fix · CNA WPZOOM Portfolio (Unknown) Fixed in 1.2.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4789
- 2026-10-03 Alias added: GHSA-xx8q-8jxm-3v8c
References
More Wpzoom Portfolio vulnerabilities
- TI-2024-07672 Cross-site scripting in WPZOOM Portfolio Lite – Filterable Portfolio Plugin CVSS 3.1MEDIUM 6.4
Sources
- CVE-2022-4789 · CVE Program
- CVE-2022-4789 · NVD
- FIRST EPSS
- GHSA-xx8q-8jxm-3v8c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences