Simple Tooltips < 2.1.4 - Contributor+ Stored XSS via Shortcode
Priority MEDIUM 58Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Simple Tooltips WordPress plugin before 2.1.4 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00605 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Simple Tooltips (Unknown): 2.1.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Simple Tooltips | before 2.1.4 | 2.1.4 | Patch available | CNA |
- Simple Tooltips VendorUnknown Affected before 2.1.4 Fixed in 2.1.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simple_tooltips_project:simple_tooltips:*:*:*:*:*:wordpress:*:* | before 2.1.4 | Vulnerable | Simple Tooltips Project |
- cpe:2.3:a:simple_tooltips_project:simple_tooltips:*:*:*:*:*:wordpress:*:* Versions before 2.1.4 Vulnerable ·Simple Tooltips Project
Remediation
- Fix · CNA Simple Tooltips (Unknown) Fixed in 2.1.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4826
- 2026-10-03 Alias added: GHSA-f234-4mv2-6gq9
References
More Simple Tooltips Project Simple Tooltips vulnerabilities
- TI-2023-11203 WordPress Simple Tooltips Plugin <= 2.1.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2022-4826 · CVE Program
- CVE-2022-4826 · NVD
- FIRST EPSS
- GHSA-f234-4mv2-6gq9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences