snoyberg keter Proxy.hs cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability has been found in snoyberg keter up to 1.8.1 and classified as problematic. This vulnerability affects unknown code of the file Keter/Proxy.hs. The manipulation of the argument host leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.8.2 is able to address this issue. The name of the patch is d41f3697926b231782a3ad8050f5af1ce5cc40b7. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217444.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| snoyberg | keter | 1.8.0; 1.8.1 | — | No fix listed | CNA |
- keter Vendorsnoyberg Affected 1.8.0; 1.8.1 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:keter_project:keter:*:*:*:*:*:*:*:* | before 1.8.2 | Vulnerable | Keter Project |
- cpe:2.3:a:keter_project:keter:*:*:*:*:*:*:*:* Versions before 1.8.2 Vulnerable ·Keter Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4877
- 2026-10-03 Alias added: GHSA-8mwx-jcg2-3xqc
References
Sources
- CVE-2022-4877 · CVE Program
- CVE-2022-4877 · NVD
- FIRST EPSS
- GHSA-8mwx-jcg2-3xqc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences