Read the docs
TI-2022-04475 Aliases CVE-2022-4882GHSA-p7m9-v9m4-xjr9

kaltura mwEmbed Share Plugin share.js cross site scripting

Priority LOW 22CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
High
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

A vulnerability was found in kaltura mwEmbed up to 2.91. It has been rated as problematic. Affected by this issue is some unknown functionality of the file modules/KalturaSupport/components/share/share.js of the component Share Plugin. The manipulation of the argument res leads to cross site scripting. The attack may be launched remotely. The complexity of an attack is rather high. The exploitation is known to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.92.rc1 is able to address this issue. The name of the patch is 4f11b6f6610acd6d89de5f8be47cf7c610643845. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217664.

Why it matters now

EPSS 0.0057 47th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
KalturamwEmbed2.0; 2.1; 2.2; 2.3; 2.4; 2.5; 2.6; 2.7; 2.8; 2.9; 2.10; 2.11; 2.12; 2.13; 2.14; 2.15; 2.16; 2.17; 2.18; 2.19; 2.20; 2.21; 2.22; 2.23; 2.24; 2.25; 2.26; 2.27; 2.28; 2.29; 2.30; 2.31; 2.32; 2.33; 2.34; 2.35; 2.36; 2.37; 2.38; 2.39; 2.40; 2.41; 2.42; 2.43; 2.44; 2.45; 2.46; 2.47; 2.48; 2.49; 2.50; 2.51; 2.52; 2.53; 2.54; 2.55; 2.56; 2.57; 2.58; 2.59; 2.60; 2.61; 2.62; 2.63; 2.64; 2.65; 2.66; 2.67; 2.68; 2.69; 2.70; 2.71; 2.72; 2.73; 2.74; 2.75; 2.76; 2.77; 2.78; 2.79; 2.80; 2.81; 2.82; 2.83; 2.84; 2.85; 2.86; 2.87; 2.88; 2.89; 2.90; 2.91—No fix listedCNA
  • mwEmbed VendorKaltura Affected 2.0; 2.1; 2.2; 2.3; 2.4; 2.5; 2.6; 2.7; 2.8; 2.9; 2.10; 2.11; 2.12; 2.13; 2.14; 2.15; 2.16; 2.17; 2.18; 2.19; 2.20; 2.21; 2.22; 2.23; 2.24; 2.25; 2.26; 2.27; 2.28; 2.29; 2.30; 2.31; 2.32; 2.33; 2.34; 2.35; 2.36; 2.37; 2.38; 2.39; 2.40; 2.41; 2.42; 2.43; 2.44; 2.45; 2.46; 2.47; 2.48; 2.49; 2.50; 2.51; 2.52; 2.53; 2.54; 2.55; 2.56; 2.57; 2.58; 2.59; 2.60; 2.61; 2.62; 2.63; 2.64; 2.65; 2.66; 2.67; 2.68; 2.69; 2.70; 2.71; 2.72; 2.73; 2.74; 2.75; 2.76; 2.77; 2.78; 2.79; 2.80; 2.81; 2.82; 2.83; 2.84; 2.85; 2.86; 2.87; 2.88; 2.89; 2.90; 2.91 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:kaltura:mwembed:*:*:*:*:*:*:*:*up to 2.91VulnerableKaltura
  • cpe:2.3:a:kaltura:mwembed:*:*:*:*:*:*:*:* Versions up to 2.91 Vulnerable ·Kaltura

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4882
  2. 2026-10-03 Alias added: GHSA-p7m9-v9m4-xjr9

References

  • TI-2022-04469 Kaltura mwEmbed DefaultSettings.php cross site scripting CVSS 3.1MEDIUM 6.1

Sources