Read the docs
TI-2022-04496 Aliases CVE-2022-4905GHSA-9j2p-8qqf-h55c

UDX Stateless Media Plugin class-settings.php setup_wizard_interface cross site scripting

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A vulnerability was found in UDX Stateless Media Plugin 3.1.1 on WordPress. It has been declared as problematic. This vulnerability affects the function setup_wizard_interface of the file lib/classes/class-settings.php. The manipulation of the argument settings leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 3.2.0 is able to address this issue. The patch is identified as 6aee7ae0b0beeb2232ce6e1c82aa7e2041ae151a. It is recommended to upgrade the affected component. VDB-220750 is the identifier assigned to this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0066 51st percentileScored 2026-11-07
Fix Fixed wpcloud/wp-stateless (Packagist): 3.2.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UDXStateless Media Plugin3.1.1—No fix listedCNA
—wpcloud/wp-stateless (Packagist)before 3.2.03.2.0Patch availableGHSA-9j2p-8qqf-h55c
  • Stateless Media Plugin VendorUDX Affected 3.1.1 Fixed in — No fix listed CNA
  • wpcloud/wp-stateless (Packagist) Vendor— Affected before 3.2.0 Fixed in 3.2.0 Patch available GHSA-9j2p-8qqf-h55c

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:udx:stateless_media_plugin:3.1.1:*:*:*:*:wordpress:*:*3.1.1VulnerableUDX
  • cpe:2.3:a:udx:stateless_media_plugin:3.1.1:*:*:*:*:wordpress:*:* Versions 3.1.1 Vulnerable ·UDX

Remediation

  • Fix · GHSA-9j2p-8qqf-h55c wpcloud/wp-stateless (Packagist) Fixed in 3.2.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-4905
  2. 2026-10-03 Alias added: GHSA-9j2p-8qqf-h55c
  3. 2026-10-08 EPSS moved to the 50th–90th percentile

References

Sources