kalcaddle KodExplorer cross-site request forgery
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
A vulnerability, which was classified as problematic, has been found in kalcaddle KodExplorer up to 4.49. Affected by this issue is some unknown functionality. The manipulation leads to cross-site request forgery. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 4.50 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-227000.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| kalcaddle | KodExplorer | 4.0; 4.1; 4.2; 4.3; 4.4; 4.5; 4.6; 4.7; 4.8; 4.9; 4.10; 4.11; 4.12; 4.13; 4.14; 4.15; 4.16; 4.17; 4.18; 4.19; 4.20; 4.21; 4.22; 4.23; 4.24; 4.25; 4.26; 4.27; 4.28; 4.29; 4.30; 4.31; 4.32; 4.33; 4.34; 4.35; 4.36; 4.37; 4.38; 4.39; 4.40; 4.41; 4.42; 4.43; 4.44; 4.45; 4.46; 4.47; 4.48; 4.49 | — | No fix listed | CNA |
- KodExplorer Vendorkalcaddle Affected 4.0; 4.1; 4.2; 4.3; 4.4; 4.5; 4.6; 4.7; 4.8; 4.9; 4.10; 4.11; 4.12; 4.13; 4.14; 4.15; 4.16; 4.17; 4.18; 4.19; 4.20; 4.21; 4.22; 4.23; 4.24; 4.25; 4.26; 4.27; 4.28; 4.29; 4.30; 4.31; 4.32; 4.33; 4.34; 4.35; 4.36; 4.37; 4.38; 4.39; 4.40; 4.41; 4.42; 4.43; 4.44; 4.45; 4.46; 4.47; 4.48; 4.49 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4944
- 2026-10-03 Alias added: GHSA-ph4w-h44m-m735
References
More kalcaddle Kodexplorer vulnerabilities
- TI-2023-06258 kalcaddle KodExplorer app.php index server-side request forgery CVSS 3.1CRITICAL 9.8
- TI-2023-27035 Reflective Cross Site Scripting (XSS) vulnerability in KodExplorer version 4.51, allows… CVSS 3.1MEDIUM 6.1
- TI-2023-18809 KodExplorer 4.51 contains a Cross-Site Scripting (XSS) vulnerability in the Description… CVSS 3.1MEDIUM 6.1
- TI-2021-14827 A Cross Site Scrtpting (XSS) vulnerability in KodExplorer 4.45 allows remote attackers to… CVSS 3.1MEDIUM 6.1
- TI-2025-24530 KodExplorer 4.52 Open Redirect Vulnerability via User Login Endpoint CVSS 4.0MEDIUM 5.3
- TI-2022-22798 Arbitrary file access in KodExplorer CVSS 3.1HIGH 8.6
Sources
- CVE-2022-4944 · CVE Program
- CVE-2022-4944 · NVD
- FIRST EPSS
- GHSA-ph4w-h44m-m735 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences