AdSanity < 1.8.2 - Authenticated Arbitrary File Upload
Priority MEDIUM 42CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-434.
Summary
The AdSanity plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the 'ajax_upload' function in versions up to, and including, 1.8.1. This makes it possible for authenticated attackers with Contributor+ level privileges to upload arbitrary files on the affected sites server which makes remote code execution possible.
Why it matters now
EPSS 0.02178 82nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed AdSanity (https://adsanityplugin.com/): 1.8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| https://adsanityplugin.com/ | AdSanity | before 1.8.2 | 1.8.2 | Patch available | CNA |
- AdSanity Vendorhttps://adsanityplugin.com/ Affected before 1.8.2 Fixed in 1.8.2 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adsanityplugin:adsanity:*:*:*:*:*:wordpress:*:* | before 1.8.2 | Vulnerable | Adsanityplugin |
| cpe:2.3:o:xen:xen:-:*:*:*:*:*:*:* | not specified by NVD | Vulnerable | Xen |
- cpe:2.3:a:adsanityplugin:adsanity:*:*:*:*:*:wordpress:*:* Versions before 1.8.2 Vulnerable ·Adsanityplugin
- cpe:2.3:o:xen:xen:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·Xen
Remediation
- Fix · CNA AdSanity (https://adsanityplugin.com/) Fixed in 1.8.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-4949
- 2026-10-03 Alias added: GHSA-v85g-h95p-h44c
References
Sources
- CVE-2022-4949 · CVE Program
- CVE-2022-4949 · NVD
- FIRST EPSS
- GHSA-v85g-h95p-h44c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences