Cross-site scripting in Jenkins Matrix Project Plugin
Priority HIGH 65CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Jenkins Matrix Project Plugin 1.19 and earlier does not escape HTML metacharacters in node and label names, and label descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Agent/Configure permission.
Why it matters now
EPSS 0.81842 99th percentileScored 2026-11-07
Fix Partial Jenkins Matrix Project Plugin (Jenkins project): 1.18.1org.jenkins-ci.plugins:matrix-project (Maven): 1.20, 1.18.1Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Matrix Project Plugin | up to 1.19 | 1.18.1 | Patch available | CNA |
| — | org.jenkins-ci.plugins:matrix-project (Maven) | 1.19 to before 1.20 | 1.20 | Patch available | GHSA-vqwg-4v6f-h6x5 |
| — | org.jenkins-ci.plugins:matrix-project (Maven) | before 1.18.1 | 1.18.1 | Patch available | GHSA-vqwg-4v6f-h6x5 |
- Jenkins Matrix Project Plugin VendorJenkins Affected up to 1.19 Fixed in 1.18.1 Patch available CNA
- org.jenkins-ci.plugins:matrix-project (Maven) Vendor— Affected 1.19 to before 1.20 Fixed in 1.20 Patch available GHSA-vqwg-4v6f-h6x5
- org.jenkins-ci.plugins:matrix-project (Maven) Vendor— Affected before 1.18.1 Fixed in 1.18.1 Patch available GHSA-vqwg-4v6f-h6x5
Remediation
- Fix · CNA Jenkins Matrix Project Plugin (Jenkins project) Fixed in 1.18.1
- Fix · GHSA-vqwg-4v6f-h6x5 org.jenkins-ci.plugins:matrix-project (Maven) Fixed in 1.20 Advisory →
- Fix · GHSA-vqwg-4v6f-h6x5 org.jenkins-ci.plugins:matrix-project (Maven) Fixed in 1.18.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2022-20615
- 2026-10-03 Alias added: GHSA-vqwg-4v6f-h6x5
References
Advisory 3
More Jenkins Matrix Project vulnerabilities
- TI-2019-15876 Protection mechanism failure in Jenkins Matrix Project Plugin CVSS 3.1CRITICAL 9.9
- TI-2020-02102 Cross-site scripting in Jenkins Matrix Project Plugin CVSS 3.1MEDIUM 5.4
- TI-2020-02101 Cross-site scripting in Jenkins Matrix Project Plugin CVSS 3.1MEDIUM 5.4
- TI-2024-15888 Path traversal in Jenkins Matrix Project Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-20615 · CVE Program
- CVE-2022-20615 · NVD
- FIRST EPSS
- GHSA-vqwg-4v6f-h6x5 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-20615 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences