Read the docs
TI-2022-05535 Aliases CVE-2022-21129GHSA-c6rx-gxqv-vr5j

OS command injection in nemo-appium

Priority HIGH 76CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.

Summary

Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function. **Note:** In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.02774 86th percentileScored 2026-11-07
Fix Fixed nemo-appium: 0.0.9nemo-appium (npm): 0.0.9

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—nemo-appiumbefore 0.0.90.0.9Patch availableCNA
—nemo-appium (npm)before 0.0.90.0.9Patch availableGHSA-c6rx-gxqv-vr5j
  • nemo-appium Vendor— Affected before 0.0.9 Fixed in 0.0.9 Patch available CNA
  • nemo-appium (npm) Vendor— Affected before 0.0.9 Fixed in 0.0.9 Patch available GHSA-c6rx-gxqv-vr5j

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:paypal:nemo-appium:*:*:*:*:*:node.js:*:*before 0.0.9VulnerablePayPal
  • cpe:2.3:a:paypal:nemo-appium:*:*:*:*:*:node.js:*:* Versions before 0.0.9 Vulnerable ·PayPal

Remediation

  • Fix · CNA nemo-appium Fixed in 0.0.9
  • Fix · GHSA-c6rx-gxqv-vr5j nemo-appium (npm) Fixed in 0.0.9 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-21129
  2. 2026-10-03 Alias added: GHSA-c6rx-gxqv-vr5j

References

Sources