Command injection in libvcs
Priority MEDIUM 48CWE-88Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.
Why it matters now
EPSS 0.03624 89th percentileScored 2026-11-07
Fix Fixed libvcs: 0.11.1libvcs (PyPI): 0.11.1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | libvcs | before 0.11.1 | 0.11.1 | Patch available | CNA |
| — | libvcs (PyPI) | before 0.11.1 | 0.11.1 | Patch available | GHSA-mv2w-4jqc-6fg4 |
| — | vcspull (PyPI) | before 1.11.1 | 1.11.1 | Patch available | GHSA-mv2w-4jqc-6fg4 |
- libvcs Vendor— Affected before 0.11.1 Fixed in 0.11.1 Patch available CNA
- libvcs (PyPI) Vendor— Affected before 0.11.1 Fixed in 0.11.1 Patch available GHSA-mv2w-4jqc-6fg4
- vcspull (PyPI) Vendor— Affected before 1.11.1 Fixed in 1.11.1 Patch available GHSA-mv2w-4jqc-6fg4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libvcs_project:libvcs:*:*:*:*:*:*:*:* | before 0.11.1 | Vulnerable | Libvcs Project |
- cpe:2.3:a:libvcs_project:libvcs:*:*:*:*:*:*:*:* Versions before 0.11.1 Vulnerable ·Libvcs Project
Remediation
- Fix · CNA libvcs Fixed in 0.11.1
- Fix · GHSA-mv2w-4jqc-6fg4 libvcs (PyPI) Fixed in 0.11.1 Advisory →
- Fix · GHSA-mv2w-4jqc-6fg4 vcspull (PyPI) Fixed in 1.11.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21187
- 2026-10-03 Alias added: GHSA-mv2w-4jqc-6fg4
References
Advisory 2
Other 4
- https://github.com/vcs-python/vcspull/commit/e1b77128a1fa0754625b5f43d8bc47956f21f33e
- https://github.com/pypa/advisory-database/tree/main/vulns/libvcs/PYSEC-2022-163.yaml
- https://github.com/vcs-python/libvcs/blob/master/CHANGES#libvcs-0111-2022-03-12
- https://github.com/vcs-python/vcspull/blob/master/CHANGES#vcspull-1111-2022-03-12
Sources
- CVE-2022-21187 · CVE Program
- CVE-2022-21187 · NVD
- FIRST EPSS
- GHSA-mv2w-4jqc-6fg4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences