scsi: target: Fix WRITE_SAME No Data Buffer crash
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-476.
Summary
In the Linux kernel, the following vulnerability has been resolved: scsi: target: Fix WRITE_SAME No Data Buffer crash In newer version of the SBC specs, we have a NDOB bit that indicates there is no data buffer that gets written out. If this bit is set using commands like "sg_write_same --ndob" we will crash in target_core_iblock/file's execute_write_same handlers when we go to access the se_cmd->t_data_sg because its NULL. This patch adds a check for the NDOB bit in the common WRITE SAME code because we don't support it. And, it adds a check for zero SG elements in each handler in case the initiator tries to send a normal WRITE SAME with no data buffer.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 3.8 and later | 5.4.294, 5.10.238, 5.15.182, 5.19 | Patch available | CNA |
- Linux VendorLinux Affected 3.8 and later Fixed in 5.4.294, 5.10.238, 5.15.182, 5.19 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | before 5.4.294; 5.5 to before 5.10.238; 5.11 to before 5.15.182; 5.16 to before 5.19 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* | 5.19 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* | 5.19 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc3:*:*:*:*:*:* | 5.19 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc4:*:*:*:*:*:* | 5.19 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc5:*:*:*:*:*:* | 5.19 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:5.19:rc6:*:*:*:*:*:* | 5.19 rc6 | Vulnerable | Linux |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions before 5.4.294; 5.5 to before 5.10.238; 5.11 to before 5.15.182; 5.16 to before 5.19 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc1:*:*:*:*:*:* Versions 5.19 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc2:*:*:*:*:*:* Versions 5.19 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc3:*:*:*:*:*:* Versions 5.19 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc4:*:*:*:*:*:* Versions 5.19 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc5:*:*:*:*:*:* Versions 5.19 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:5.19:rc6:*:*:*:*:*:* Versions 5.19 rc6 Vulnerable ·Linux
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.4.294, 5.10.238, 5.15.182, 5.19
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21546
- 2026-10-03 Alias added: GHSA-4f99-6w2j-877c
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2022-21546 · CVE Program
- CVE-2022-21546 · NVD
- FIRST EPSS
- GHSA-4f99-6w2j-877c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences