Incorrect Default Permissions in log4js-node
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
log4js-node is a port of log4js to node.js. In affected versions default file permissions for log files created by the file, fileSync and dateFile appenders are world-readable (in unix). This could cause problems if log files contain sensitive information. This would affect any users that have not supplied their own permissions for the files via the mode parameter in the config. Users are advised to update.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| log4js-node | log4js-node | before 6.4.0 | 6.4.0 | Patch available | CNA |
| — | log4js (npm) | before 6.4.0 | 6.4.0 | Patch available | GHSA-82v2-mx6x-wq7q |
- log4js-node Vendorlog4js-node Affected before 6.4.0 Fixed in 6.4.0 Patch available CNA
- log4js (npm) Vendor— Affected before 6.4.0 Fixed in 6.4.0 Patch available GHSA-82v2-mx6x-wq7q
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:log4js_project:log4js:*:*:*:*:*:node.js:*:* | before 6.4.0 | Vulnerable | Log4js Project |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:log4js_project:log4js:*:*:*:*:*:node.js:*:* Versions before 6.4.0 Vulnerable ·Log4js Project
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA log4js-node (log4js-node) Fixed in 6.4.0
- Fix · GHSA-82v2-mx6x-wq7q log4js (npm) Fixed in 6.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21704
- 2026-10-03 Alias added: GHSA-82v2-mx6x-wq7q
References
Patch 3
Advisory 3
Sources
- CVE-2022-21704 · CVE Program
- CVE-2022-21704 · NVD
- FIRST EPSS
- GHSA-82v2-mx6x-wq7q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences