Cross-site Scripting in ShortDescription extension
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
ShortDescription is a MediaWiki extension that provides local short description support. A cross-site scripting (XSS) vulnerability exists in versions prior to 2.3.4. On a wiki that has the ShortDescription enabled, XSS can be triggered on any page or the page with the action=info parameter, which displays the shortdesc property. This is achieved using the wikitext `{{SHORTDESC:<img src=x onerror=alert()>}}`. This issue has a patch in version 2.3.4.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| StarCitizenTools | mediawiki-extensions-ShortDescription | before 2.3.4 | 2.3.4 | Patch available | CNA |
- mediawiki-extensions-ShortDescription VendorStarCitizenTools Affected before 2.3.4 Fixed in 2.3.4 Patch available CNA
Remediation
- Fix · CNA mediawiki-extensions-ShortDescription (StarCitizenTools) Fixed in 2.3.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21710
References
More StarCitizenTools vulnerabilities
- TI-2025-33331 Citizen Short Description stored XSS vulnerability through wikitext CVSS 3.1HIGH 8.6
- TI-2025-33330 Citizen is vulnerable to stored XSS attack in the legacy search bar CVSS 3.1HIGH 8.6
- TI-2025-33086 TabberNeue vulnerable to Stored XSS through wikitext CVSS 3.1HIGH 8.6
- TI-2025-15572 Cross-site Scripting in TabberTransclude in Extension:TabberNeue CVSS 3.1HIGH 8.6
- TI-2025-33332 Citizen stored XSS vulnerability through short descriptions CVSS 3.1HIGH 8.6
- TI-2024-23953 Citizen has a Stored Cross-Site Scripting Vulnerability by editing MediaWiki:Tagline CVSS 3.1MEDIUM 6.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences