Cross-site scripting (XSS) in grapesjs
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
The package grapesjs before 0.19.5 are vulnerable to Cross-site Scripting (XSS) due to an improper sanitization of the class name in Selector Manager.
Why it matters now
EPSS 0.00796 56th percentileScored 2026-11-07
Fix Fixed grapesjs: 0.19.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | grapesjs | before 0.19.5 | 0.19.5 | Patch available | CNA |
| — | grapesjs (npm) | all versions | — | No fix listed | GHSA-589f-c66p-hxr4 |
- grapesjs Vendor— Affected before 0.19.5 Fixed in 0.19.5 Patch available CNA
- grapesjs (npm) Vendor— Affected all versions Fixed in — No fix listed GHSA-589f-c66p-hxr4
Remediation
- Fix · CNA grapesjs Fixed in 0.19.5
Timeline
- 2026-10-02 Threatist record created from CVE-2022-21802
- 2026-10-03 Alias added: GHSA-589f-c66p-hxr4
References
Advisory 3
Sources
- CVE-2022-21802 · CVE Program
- CVE-2022-21802 · NVD
- FIRST EPSS
- GHSA-589f-c66p-hxr4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences