Read the docs
TI-2022-06202 Aliases CVE-2022-21831GHSA-w749-p3v6-hccq

Code injection in https://github.com/rails/rails

Priority MEDIUM 48CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

A code injection vulnerability exists in the Active Storage >= v5.2.0 that could allow an attacker to execute code via image_processing arguments.

Why it matters now

EPSS 0.03098 87th percentileScored 2026-11-07
Fix Fixed activestorage (RubyGems): 5.2.6.3, 6.0.4.7, 6.1.4.7 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—https://github.com/rails/rails7.0.2.3, 6.1.4.7, 6.0.4.7, 5.2.6.3—No fix listedCNA
—activestorage (RubyGems)5.2.0 to before 5.2.6.35.2.6.3Patch availableGHSA-w749-p3v6-hccq
—activestorage (RubyGems)6.0.0 to before 6.0.4.76.0.4.7Patch availableGHSA-w749-p3v6-hccq
—activestorage (RubyGems)6.1.0 to before 6.1.4.76.1.4.7Patch availableGHSA-w749-p3v6-hccq
—activestorage (RubyGems)7.0.0 to before 7.0.2.37.0.2.3Patch availableGHSA-w749-p3v6-hccq
  • https://github.com/rails/rails Vendor— Affected 7.0.2.3, 6.1.4.7, 6.0.4.7, 5.2.6.3 Fixed in — No fix listed CNA
  • activestorage (RubyGems) Vendor— Affected 5.2.0 to before 5.2.6.3 Fixed in 5.2.6.3 Patch available GHSA-w749-p3v6-hccq
  • activestorage (RubyGems) Vendor— Affected 6.0.0 to before 6.0.4.7 Fixed in 6.0.4.7 Patch available GHSA-w749-p3v6-hccq
  • activestorage (RubyGems) Vendor— Affected 6.1.0 to before 6.1.4.7 Fixed in 6.1.4.7 Patch available GHSA-w749-p3v6-hccq
  • activestorage (RubyGems) Vendor— Affected 7.0.0 to before 7.0.2.3 Fixed in 7.0.2.3 Patch available GHSA-w749-p3v6-hccq

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:rubyonrails:active_storage:*:*:*:*:*:ruby:*:*5.2.0 to before 5.2.6.3; 6.0.0 to before 6.0.4.7; 6.1.0 to before 6.1.4.7; 7.0.0 to before 7.0.2.3VulnerableRails
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
  • cpe:2.3:a:rubyonrails:active_storage:*:*:*:*:*:ruby:*:* Versions 5.2.0 to before 5.2.6.3; 6.0.0 to before 6.0.4.7; 6.1.0 to before 6.1.4.7; 7.0.0 to before 7.0.2.3 Vulnerable ·Rails
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-w749-p3v6-hccq activestorage (RubyGems) Fixed in 5.2.6.3 Advisory →
  • Fix · GHSA-w749-p3v6-hccq activestorage (RubyGems) Fixed in 6.0.4.7 Advisory →
  • Fix · GHSA-w749-p3v6-hccq activestorage (RubyGems) Fixed in 6.1.4.7 Advisory →
  • Fix · GHSA-w749-p3v6-hccq activestorage (RubyGems) Fixed in 7.0.2.3 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Satellite 6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-21831
  2. 2026-10-03 Alias added: GHSA-w749-p3v6-hccq

References

Sources