Apple macOS: An application may be able to access restricted files
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A permissions issue was addressed with improved validation. This issue is fixed in Security Update 2022-001 Catalina, macOS Monterey 12.2, macOS Big Sur 11.6.3. An application may be able to access restricted files.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | macOS | before 12.2 | 12.2 | Patch available | CNA |
| Apple | macOS | before 11.6 | 11.6 | Patch available | CNA |
| Apple | macOS | before 2022 | 2022 | Patch available | CNA |
- macOS VendorApple Affected before 12.2 Fixed in 12.2 Patch available CNA
- macOS VendorApple Affected before 11.6 Fixed in 11.6 Patch available CNA
- macOS VendorApple Affected before 2022 Fixed in 2022 Patch available CNA
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* | 10.15 to before 10.15.7 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:* | 10.15.7 security_update_2020-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-001:*:*:*:*:*:* | 10.15.7 security_update_2021-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-002:*:*:*:*:*:* | 10.15.7 security_update_2021-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-003:*:*:*:*:*:* | 10.15.7 security_update_2021-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-004:*:*:*:*:*:* | 10.15.7 security_update_2021-004 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-005:*:*:*:*:*:* | 10.15.7 security_update_2021-005 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-006:*:*:*:*:*:* | 10.15.7 security_update_2021-006 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-007:*:*:*:*:*:* | 10.15.7 security_update_2021-007 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-008:*:*:*:*:*:* | 10.15.7 security_update_2021-008 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* Versions 10.15 to before 10.15.7 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:* Versions 10.15.7 security_update_2020-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-001:*:*:*:*:*:* Versions 10.15.7 security_update_2021-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-002:*:*:*:*:*:* Versions 10.15.7 security_update_2021-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-003:*:*:*:*:*:* Versions 10.15.7 security_update_2021-003 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-004:*:*:*:*:*:* Versions 10.15.7 security_update_2021-004 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-005:*:*:*:*:*:* Versions 10.15.7 security_update_2021-005 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-006:*:*:*:*:*:* Versions 10.15.7 security_update_2021-006 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-007:*:*:*:*:*:* Versions 10.15.7 security_update_2021-007 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-008:*:*:*:*:*:* Versions 10.15.7 security_update_2021-008 Vulnerable ·Apple
Remediation
- Fix · CNA macOS (Apple) Fixed in 12.2
- Fix · CNA macOS (Apple) Fixed in 11.6
- Fix · CNA macOS (Apple) Fixed in 2022
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS 11.6
23 records Highest priority Priority CRITICAL 1 CRITICAL, 1 MEDIUM, 21 LOW
Other records, highest priority first
- TI-2022-06854 Out-of-bounds write in Apple iOS and iPadOSPriority CRITICAL 100
- TI-2022-06896 Apple iOS and iPadOS: A malicious application may be able to elevate privilegesPriority MEDIUM 45
- TI-2022-06848 Apple iOS and iPadOS: Processing a maliciously crafted STL file may lead to unexpected…Priority LOW 38
- Release ·
Apple macOS 2022
18 records Highest priority Priority LOW 18 LOW
Other records, highest priority first
- TI-2022-06848 Apple iOS and iPadOS: Processing a maliciously crafted STL file may lead to unexpected…Priority LOW 38
- TI-2022-06881 Use after free in Apple iOS and iPadOSPriority LOW 37
- TI-2022-06880 Use after free in Apple iOS and iPadOSPriority LOW 37
Show 1 more group
- Release ·
Apple macOS 12.2
14 records Highest priority Priority CRITICAL 2 CRITICAL, 2 MEDIUM, 10 LOW
Other records, highest priority first
- TI-2022-06854 Out-of-bounds write in Apple iOS and iPadOSPriority CRITICAL 100
- TI-2022-06885 Use after free in Apple SafariPriority CRITICAL 97
- TI-2022-06853 Out-of-bounds write in Apple macOSPriority MEDIUM 46
Timeline
- 2026-10-02 Threatist record created from CVE-2022-22583
- 2026-10-03 Alias added: GHSA-fqhm-44xp-628c
References
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2022-22583 · CVE Program
- CVE-2022-22583 · NVD
- FIRST EPSS
- GHSA-fqhm-44xp-628c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences