Read the docs
TI-2022-06873 Aliases CVE-2022-22607GHSA-2j5p-8qm3-j27m

Out-of-bounds read in Apple Xcode

Priority LOW 36CWE-125Published · Updated

Key facts

Attack vector
Local
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

An out-of-bounds read was addressed with improved bounds checking. This issue is fixed in Xcode 13.3. Opening a maliciously crafted file may lead to unexpected application termination or arbitrary code execution.

Why it matters now

EPSS 0.00881 59th percentileScored 2026-11-07
Fix Fixed Xcode (Apple): 13.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
AppleXcodebefore 13.313.3Patch availableCNA
  • Xcode VendorApple Affected before 13.3 Fixed in 13.3 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apple:xcode:*:*:*:*:*:*:*:*before 13.3VulnerableApple
  • cpe:2.3:a:apple:xcode:*:*:*:*:*:*:*:* Versions before 13.3 Vulnerable ·Apple

Remediation

  • Fix · CNA Xcode (Apple) Fixed in 13.3

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apple Xcode 13.3

    8 records Highest priority Priority LOW 8 LOW

    Other records, highest priority first

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-22607
  2. 2026-10-03 Alias added: GHSA-2j5p-8qm3-j27m

References

  • TI-2021-19919 Apache Log4j2 JNDI features do not protect against attacker controlled LDAP and other JNDI related endpoints KEVCVSS 3.1CRITICAL 10.0
  • TI-2025-30709 Git allows arbitrary code execution through broken config quoting KEVCVSS 3.1HIGH 8.1
  • TI-2004-02557 distcc 2.x, as used in XCode 1.5 and others, when not configured to restrict access to… CVSS 2.0HIGH 9.3
  • TI-2014-07619 Git before 1.8.5.6, 1.9.x before 1.9.5, 2.0.x before 2.0.5, 2.1.x before 2.1.4, and 2.2.x… CVSS 3.1CRITICAL 9.8
  • TI-2021-04400 malicious repositories can execute remote code while cloning CVSS 3.1HIGH 8.0
  • TI-2016-00666 The resolver in nginx before 1.8.1 and 1.9.x before 1.9.10 allows remote attackers to… CVSS 3.1HIGH 7.5
See all 99 →

Sources