Uncontrolled resource consumption in Spring Security OAuth
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
<Issue Description> Spring Security OAuth versions 2.5.x prior to 2.5.2 and older unsupported versions are susceptible to a Denial-of-Service (DoS) attack via the initiation of the Authorization Request in an OAuth 2.0 Client application. A malicious user or attacker can send multiple requests initiating the Authorization Request for the Authorization Code Grant, which has the potential of exhausting system resources using a single session. This vulnerability exposes OAuth 2.0 Client applications only.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Spring Security OAuth | <affected versions> Spring Security OAuth 2.5.x prior to 2.5.2 and older unsupported versions | — | No fix listed | CNA |
| — | org.springframework.security.oauth:spring-security-oauth2 (Maven) | 2.5.0.RELEASE to before 2.5.2.RELEASE | 2.5.2.RELEASE | Patch available | GHSA-c2cp-3xj9-97w9 |
| — | org.springframework.security.oauth:spring-security-oauth2 (Maven) | 2.4.0.RELEASE to before 2.4.2.RELEASE | 2.4.2.RELEASE | Patch available | GHSA-c2cp-3xj9-97w9 |
- Spring Security OAuth Vendor— Affected <affected versions> Spring Security OAuth 2.5.x prior to 2.5.2 and older unsupported versions Fixed in — No fix listed CNA
- org.springframework.security.oauth:spring-security-oauth2 (Maven) Vendor— Affected 2.5.0.RELEASE to before 2.5.2.RELEASE Fixed in 2.5.2.RELEASE Patch available GHSA-c2cp-3xj9-97w9
- org.springframework.security.oauth:spring-security-oauth2 (Maven) Vendor— Affected 2.4.0.RELEASE to before 2.4.2.RELEASE Fixed in 2.4.2.RELEASE Patch available GHSA-c2cp-3xj9-97w9
Remediation
- Fix · GHSA-c2cp-3xj9-97w9 org.springframework.security.oauth:spring-security-oauth2 (Maven) Fixed in 2.5.2.RELEASE Advisory →
- Fix · GHSA-c2cp-3xj9-97w9 org.springframework.security.oauth:spring-security-oauth2 (Maven) Fixed in 2.4.2.RELEASE Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-22969
- 2026-10-03 Alias added: GHSA-c2cp-3xj9-97w9
References
Sources
- CVE-2022-22969 · CVE Program
- CVE-2022-22969 · NVD
- FIRST EPSS
- GHSA-c2cp-3xj9-97w9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences