Observable discrepancy in Jenkins Configuration as Code Plugin
Priority LOW 26CWE-203Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-203.
Summary
Jenkins Configuration as Code Plugin 1.55 and earlier used a non-constant time comparison function when validating an authentication token allowing attackers to use statistical methods to obtain a valid authentication token.
Why it matters now
EPSS 0.01158 67th percentileScored 2026-11-07
Fix Partial Jenkins Configuration as Code Plugin (Jenkins project): 1.47.1, 1.53.1, 1.54.1io.jenkins:configuration-as-code (Maven): 1.55.1, 1.54.1, 1.53.1 +1Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Configuration as Code Plugin | up to 1.55 | 1.47.1, 1.53.1, 1.54.1 | Patch available | CNA |
| — | io.jenkins:configuration-as-code (Maven) | 1.55 to before 1.55.1 | 1.55.1 | Patch available | GHSA-fpj7-9xm6-8hgr |
| — | io.jenkins:configuration-as-code (Maven) | 1.54 to before 1.54.1 | 1.54.1 | Patch available | GHSA-fpj7-9xm6-8hgr |
| — | io.jenkins:configuration-as-code (Maven) | 1.48 to before 1.53.1 | 1.53.1 | Patch available | GHSA-fpj7-9xm6-8hgr |
| — | io.jenkins:configuration-as-code (Maven) | before 1.47.1 | 1.47.1 | Patch available | GHSA-fpj7-9xm6-8hgr |
- Jenkins Configuration as Code Plugin VendorJenkins Affected up to 1.55 Fixed in 1.47.1, 1.53.1, 1.54.1 Patch available CNA
- io.jenkins:configuration-as-code (Maven) Vendor— Affected 1.55 to before 1.55.1 Fixed in 1.55.1 Patch available GHSA-fpj7-9xm6-8hgr
- io.jenkins:configuration-as-code (Maven) Vendor— Affected 1.54 to before 1.54.1 Fixed in 1.54.1 Patch available GHSA-fpj7-9xm6-8hgr
- io.jenkins:configuration-as-code (Maven) Vendor— Affected 1.48 to before 1.53.1 Fixed in 1.53.1 Patch available GHSA-fpj7-9xm6-8hgr
- io.jenkins:configuration-as-code (Maven) Vendor— Affected before 1.47.1 Fixed in 1.47.1 Patch available GHSA-fpj7-9xm6-8hgr
Remediation
- Fix · CNA Jenkins Configuration as Code Plugin (Jenkins project) Fixed in 1.47.1, 1.53.1, 1.54.1
- Fix · GHSA-fpj7-9xm6-8hgr io.jenkins:configuration-as-code (Maven) Fixed in 1.55.1 Advisory →
- Fix · GHSA-fpj7-9xm6-8hgr io.jenkins:configuration-as-code (Maven) Fixed in 1.54.1 Advisory →
- Fix · GHSA-fpj7-9xm6-8hgr io.jenkins:configuration-as-code (Maven) Fixed in 1.53.1 Advisory →
- Fix · GHSA-fpj7-9xm6-8hgr io.jenkins:configuration-as-code (Maven) Fixed in 1.47.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 3.11 | Affected | No fix yet: Fix deferred |
| Red Hat OpenShift Container Platform 4 | Affected | No fix yet |
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23106
- 2026-10-03 Alias added: GHSA-fpj7-9xm6-8hgr
References
Advisory 3
More Jenkins Configuration As Code vulnerabilities
- TI-2018-15965 A exposure of sensitive information vulnerability exists in Jenkins Configuration as Code… CVSS 3.0HIGH 8.8
- TI-2018-15964 A exposure of sensitive information vulnerability exists in Jenkins Configuration as Code… CVSS 3.0MEDIUM 6.5
- TI-2019-07671 Improper output encoding in Jenkins Configuration as Code Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-07676 Sensitive information in log files in Jenkins Configuration as Code Plugin CVSS 3.1MEDIUM 5.5
- TI-2019-07654 Insufficiently protected credentials in Jenkins Configuration as Code Plugin CVSS 3.1MEDIUM 5.5
- TI-2019-07672 Cleartext transmission of sensitive information in Jenkins Configuration as Code Plugin CVSS 3.1MEDIUM 4.9
Sources
- CVE-2022-23106 · CVE Program
- CVE-2022-23106 · NVD
- FIRST EPSS
- GHSA-fpj7-9xm6-8hgr · GitHub Advisory Database · CC BY 4.0
- CVE-2022-23106 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences