Jenkins Conjur Secrets Plugin 1.0.9 and earlier implements functionality that allows…
Priority LOW 34CWE-311Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-311.
Summary
Jenkins Conjur Secrets Plugin 1.0.9 and earlier implements functionality that allows attackers able to control agent processes to decrypt secrets stored in Jenkins obtained through another method.
Why it matters now
EPSS 0.00855 58th percentileScored 2026-11-07
Fix Fixed org.conjur.jenkins:conjur-credentials (Maven): 1.0.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Conjur Secrets Plugin | up to 1.0.9 | — | No fix listed | CNA |
| — | org.conjur.jenkins:conjur-credentials (Maven) | before 1.0.10 | 1.0.10 | Patch available | GHSA-g7fx-mmjc-r7gv |
- Jenkins Conjur Secrets Plugin VendorJenkins Affected up to 1.0.9 Fixed in — No fix listed CNA
- org.conjur.jenkins:conjur-credentials (Maven) Vendor— Affected before 1.0.10 Fixed in 1.0.10 Patch available GHSA-g7fx-mmjc-r7gv
Remediation
- Fix · GHSA-g7fx-mmjc-r7gv org.conjur.jenkins:conjur-credentials (Maven) Fixed in 1.0.10 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Jenkins Conjur Secrets Plugin unspecified
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2022-07286 Insufficiently protected credentials in Jenkins Conjur Secrets PluginPriority LOW 36
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23116
- 2026-10-03 Alias added: GHSA-g7fx-mmjc-r7gv
References
Advisory 3
More Jenkins Conjur Secrets vulnerabilities
- TI-2022-07286 Insufficiently protected credentials in Jenkins Conjur Secrets Plugin CVSS 3.1HIGH 7.5
- TI-2022-08903 Missing authorization in Jenkins Conjur Secrets Plugin CVSS 3.1MEDIUM 4.3
Sources
- CVE-2022-23116 · CVE Program
- CVE-2022-23116 · NVD
- FIRST EPSS
- GHSA-g7fx-mmjc-r7gv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences