Incorrect permissions of [/var/run/zabbix] forces dac_override
Priority LOW 34CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-284.
Summary
During Zabbix installation from RPM, DAC_OVERRIDE SELinux capability is in use to access PID files in [/var/run/zabbix] folder. In this case, Zabbix Proxy or Server processes can bypass file read, write and execute permissions check on the file system level
Why it matters now
EPSS 0.00856 58th percentileScored 2026-11-07
Fix Fixed Proxy, Server (Zabbix): 5.0.19, 5.4.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Zabbix | Proxy, Server | 4.0.0 - 4.0.36; 5.0.0 – 5.0.18; 5.4.0 – 5.4.8 | 5.0.19, 5.4.9 | Patch available | CNA |
- Proxy, Server VendorZabbix Affected 4.0.0 - 4.0.36; 5.0.0 – 5.0.18; 5.4.0 – 5.4.8 Fixed in 5.0.19, 5.4.9 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zabbix:zabbix:*:*:*:*:*:*:*:* | 4.0.0 – 4.0.36; 5.0.0 – 5.0.18; 5.4.0 – 5.4.8 | Vulnerable | Zabbix |
| cpe:2.3:a:zabbix:zabbix:6.0.0:alpha1:*:*:*:*:*:* | 6.0.0 alpha1 | Vulnerable | Zabbix |
| cpe:2.3:a:zabbix:zabbix:6.0.0:alpha2:*:*:*:*:*:* | 6.0.0 alpha2 | Vulnerable | Zabbix |
| cpe:2.3:a:zabbix:zabbix:6.0.0:alpha3:*:*:*:*:*:* | 6.0.0 alpha3 | Vulnerable | Zabbix |
| cpe:2.3:a:zabbix:zabbix:6.0.0:alpha4:*:*:*:*:*:* | 6.0.0 alpha4 | Vulnerable | Zabbix |
| cpe:2.3:a:zabbix:zabbix:6.0.0:alpha5:*:*:*:*:*:* | 6.0.0 alpha5 | Vulnerable | Zabbix |
| cpe:2.3:a:zabbix:zabbix:6.0.0:alpha6:*:*:*:*:*:* | 6.0.0 alpha6 | Vulnerable | Zabbix |
| cpe:2.3:a:zabbix:zabbix:6.0.0:alpha7:*:*:*:*:*:* | 6.0.0 alpha7 | Vulnerable | Zabbix |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
- cpe:2.3:a:zabbix:zabbix:*:*:*:*:*:*:*:* Versions 4.0.0 – 4.0.36; 5.0.0 – 5.0.18; 5.4.0 – 5.4.8 Vulnerable ·Zabbix
- cpe:2.3:a:zabbix:zabbix:6.0.0:alpha1:*:*:*:*:*:* Versions 6.0.0 alpha1 Vulnerable ·Zabbix
- cpe:2.3:a:zabbix:zabbix:6.0.0:alpha2:*:*:*:*:*:* Versions 6.0.0 alpha2 Vulnerable ·Zabbix
- cpe:2.3:a:zabbix:zabbix:6.0.0:alpha3:*:*:*:*:*:* Versions 6.0.0 alpha3 Vulnerable ·Zabbix
- cpe:2.3:a:zabbix:zabbix:6.0.0:alpha4:*:*:*:*:*:* Versions 6.0.0 alpha4 Vulnerable ·Zabbix
- cpe:2.3:a:zabbix:zabbix:6.0.0:alpha5:*:*:*:*:*:* Versions 6.0.0 alpha5 Vulnerable ·Zabbix
- cpe:2.3:a:zabbix:zabbix:6.0.0:alpha6:*:*:*:*:*:* Versions 6.0.0 alpha6 Vulnerable ·Zabbix
- cpe:2.3:a:zabbix:zabbix:6.0.0:alpha7:*:*:*:*:*:* Versions 6.0.0 alpha7 Vulnerable ·Zabbix
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA Proxy, Server (Zabbix) Fixed in 5.0.19, 5.4.9
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23132
- 2026-10-03 Alias added: GHSA-qqcg-7f79-v65c
References
More Zabbix vulnerabilities
- TI-2022-07300 Authentication bypass by spoofing in Zabbix Frontend KEVCVSS 3.1CRITICAL 9.8
- TI-2024-28315 SQL injection in user.get API CVSS 3.1CRITICAL 9.9
- TI-2016-08210 SQL injection vulnerability in Zabbix before 2.2.14 and 3.0 before 3.0.4 allows remote… CVSS 3.0CRITICAL 9.8
- TI-2013-04884 Multiple SQL injection vulnerabilities in Zabbix 1.8.x before 1.8.18rc1, 2.0.x before 2.0.9rc1, and 2.1.x before 2.1.7. CVSS 3.1CRITICAL 9.8
- TI-2022-07303 Possible view of the setup pages by unauthenticated users if config file already exists KEVCVSS 3.1MEDIUM 5.3
- TI-2024-14721 Time Based SQL Injection in Zabbix Server Audit Log CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-23132 · CVE Program
- CVE-2022-23132 · NVD
- FIRST EPSS
- GHSA-qqcg-7f79-v65c · GitHub Advisory Database · CC BY 4.0
- CVE-2022-23132 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences