Read the docs
TI-2022-07577 Aliases CVE-2022-23518GHSA-mcvf-2q2m-x72m

Improper neutralization of data URIs allows XSS in rails-html-sanitizer

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Partial Red Hat: 1 fixed, 2 without a fix

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.

Summary

rails-html-sanitizer is responsible for sanitizing HTML fragments in Rails applications. Versions >= 1.0.3, < 1.4.4 are vulnerable to cross-site scripting via data URIs when used in combination with Loofah >= 2.1.0. This issue is patched in version 1.4.4.

Why it matters now

EPSS 0.00925 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial rails-html-sanitizer (rails): 1.4.4rails-html-sanitizer (RubyGems): 1.4.4Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Railsrails-html-sanitizer1.0.3 to before 1.4.41.4.4Patch availableCNA
—rails-html-sanitizer (RubyGems)1.0.3 to before 1.4.41.4.4Patch availableGHSA-mcvf-2q2m-x72m
  • rails-html-sanitizer VendorRails Affected 1.0.3 to before 1.4.4 Fixed in 1.4.4 Patch available CNA
  • rails-html-sanitizer (RubyGems) Vendor— Affected 1.0.3 to before 1.4.4 Fixed in 1.4.4 Patch available GHSA-mcvf-2q2m-x72m

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:rubyonrails:rails_html_sanitizers:*:*:*:*:*:rails:*:*1.0.3 to before 1.4.4VulnerableRails
cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*10.0VulnerableDebian
cpe:2.3:a:loofah_project:loofah:*:*:*:*:*:ruby:*:*2.1.0 to before 2.19.1Vulnerableflavorjones
  • cpe:2.3:a:rubyonrails:rails_html_sanitizers:*:*:*:*:*:rails:*:* Versions 1.0.3 to before 1.4.4 Vulnerable ·Rails
  • cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
  • cpe:2.3:a:loofah_project:loofah:*:*:*:*:*:ruby:*:* Versions 2.1.0 to before 2.19.1 Vulnerable ·flavorjones

Remediation

  • Fix · CNA rails-html-sanitizer (rails) Fixed in 1.4.4
  • Fix · GHSA-mcvf-2q2m-x72m rails-html-sanitizer (RubyGems) Fixed in 1.4.4 Advisory →

Red Hat 1 advisory

  • RHSA-2023:2097 Released 2023-05-03 · Red Hat rating Important
    Satellite 6.13 Release
    • Red Hat Satellite 6.13 for RHEL 8 ansible-collection-redhat-satellite-3.9.0-2.el8sat, ansible-collection-redhat-satellite_operations-1.3.0-2.el8sat, ansible-lint-5.0.8-4.el8pc +47

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat 3scale API Management Platform 2AffectedNo fix planned: Will not fix
Red Hat Satellite 6AffectedNo fix yet
Red Hat Satellite 6.13 for RHEL 8Fixed RHSA-2023:2097
Not affected: 1 product
  • Red Hat Satellite 6.13 for RHEL 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-23518
  2. 2026-10-03 Alias added: GHSA-mcvf-2q2m-x72m

References

  • TI-2022-13919 Cross-site scripting in https://github.com/rails/rails-html-sanitizer CVSS 3.1MEDIUM 6.1
  • TI-2024-36144 Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0 CVSS 4.0LOW 2.3
  • TI-2022-07576 Inefficient Regular Expression Complexity in rails-html-sanitizer CVSS 3.1HIGH 7.5
  • TI-2022-07578 Possible XSS vulnerability with certain configurations of rails-html-sanitizer CVSS 3.1HIGH 7.2
  • TI-2022-07579 rails-html-sanitizer contains an incomplete fix for an XSS vulnerability CVSS 3.1MEDIUM 6.1
  • TI-2024-36148 Possible XSS vulnerability with certain configurations of rails-html-sanitizer 1.6.0 CVSS 4.0LOW 2.3
See all 9 →

Sources