Discourse vulnerable to bypass of post max_length using HTML comments
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Discourse is an option source discussion platform. Prior to version 2.8.14 on the `stable` branch and version 2.9.0.beta16 on the `beta` and `tests-passed` branches, users can create posts with raw body longer than the `max_length` site setting by including html comments that are not counted toward the character limit. This issue is patched in versions 2.8.14 and 2.9.0.beta16. There are no known workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| discourse | discourse | 2.8.14 to before 2.8.14; 2.9.0.beta0 – 2.9.0.beta0; 2.9.0.beta16 to before 2.9.0.beta16 | 2.8.14, 2.9.0.beta16 | Patch available | CNA |
- discourse Vendordiscourse Affected 2.8.14 to before 2.8.14; 2.9.0.beta0 – 2.9.0.beta0; 2.9.0.beta16 to before 2.9.0.beta16 Fixed in 2.8.14, 2.9.0.beta16 Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* | before 2.8.14 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta1:*:*:*:*:*:* | 2.9.0 beta1 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta10:*:*:*:*:*:* | 2.9.0 beta10 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta11:*:*:*:*:*:* | 2.9.0 beta11 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta12:*:*:*:*:*:* | 2.9.0 beta12 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta13:*:*:*:*:*:* | 2.9.0 beta13 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta14:*:*:*:*:*:* | 2.9.0 beta14 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta2:*:*:*:*:*:* | 2.9.0 beta2 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta3:*:*:*:*:*:* | 2.9.0 beta3 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta4:*:*:*:*:*:* | 2.9.0 beta4 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:*:*:*:*:*:*:*:* Versions before 2.8.14 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta1:*:*:*:*:*:* Versions 2.9.0 beta1 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta10:*:*:*:*:*:* Versions 2.9.0 beta10 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta11:*:*:*:*:*:* Versions 2.9.0 beta11 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta12:*:*:*:*:*:* Versions 2.9.0 beta12 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta13:*:*:*:*:*:* Versions 2.9.0 beta13 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta14:*:*:*:*:*:* Versions 2.9.0 beta14 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta2:*:*:*:*:*:* Versions 2.9.0 beta2 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta3:*:*:*:*:*:* Versions 2.9.0 beta3 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta4:*:*:*:*:*:* Versions 2.9.0 beta4 Vulnerable ·discourse
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:discourse:discourse:2.9.0:beta5:*:*:*:*:*:* | 2.9.0 beta5 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta6:*:*:*:*:*:* | 2.9.0 beta6 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta7:*:*:*:*:*:* | 2.9.0 beta7 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:2.9.0:beta8:*:*:*:*:*:* | 2.9.0 beta8 | Vulnerable | discourse |
| cpe:2.3:a:discourse:discourse:3.0.0:beta15:*:*:*:*:*:* | 3.0.0 beta15 | Vulnerable | discourse |
- cpe:2.3:a:discourse:discourse:2.9.0:beta5:*:*:*:*:*:* Versions 2.9.0 beta5 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta6:*:*:*:*:*:* Versions 2.9.0 beta6 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta7:*:*:*:*:*:* Versions 2.9.0 beta7 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:2.9.0:beta8:*:*:*:*:*:* Versions 2.9.0 beta8 Vulnerable ·discourse
- cpe:2.3:a:discourse:discourse:3.0.0:beta15:*:*:*:*:*:* Versions 3.0.0 beta15 Vulnerable ·discourse
Remediation
- Fix · CNA discourse (discourse) Fixed in 2.8.14, 2.9.0.beta16
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23549
References
More Discourse vulnerabilities
- TI-2021-19656 Denial of Service in discourse CVSS 3.1MEDIUM 6.8
- TI-2024-36150 Potential Backup file leaked via Nginx in Discourse CVSS 3.1HIGH 7.5
- TI-2021-18002 RCE via malicious SNS subscription payload CVSS 3.1CRITICAL 10.0
- TI-2026-24651 Discourse: Open redirect via `sso_destination_url` cookie in `enter` CVSS 4.0MEDIUM 5.1
- TI-2026-22278 Discourse leaks private topic title and post excerpt via user action API endpoint CVSS 4.0HIGH 8.7
- TI-2023-24152 Unauthenticated access to new private chat messages in Discourse CVSS 3.1HIGH 7.5
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences