Read the docs
TI-2022-07683 Aliases CVE-2022-23631GHSA-5888-ffcr-r425

Prototype Pollution leading to Remote Code Execution in superjson

Priority MEDIUM 47CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

superjson is a program to allow JavaScript expressions to be serialized to a superset of JSON. In versions prior to 1.8.1 superjson allows input to run arbitrary code on any server using superjson input without prior authentication or knowledge. The only requirement is that the server implements at least one endpoint which uses superjson during request processing. This has been patched in superjson 1.8.1. Users are advised to update. There are no known workarounds for this issue.

Why it matters now

EPSS 0.02684 85th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed superjson (blitz-js): 1.8.0superjson (npm): 1.8.1+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
blitz-jssuperjsonbefore 1.8.01.8.0Patch availableCNA
—superjson (npm)before 1.8.11.8.1Patch availableGHSA-5888-ffcr-r425
—blitz (npm)before 0.45.30.45.3Patch availableGHSA-5888-ffcr-r425
  • superjson Vendorblitz-js Affected before 1.8.0 Fixed in 1.8.0 Patch available CNA
  • superjson (npm) Vendor— Affected before 1.8.1 Fixed in 1.8.1 Patch available GHSA-5888-ffcr-r425
  • blitz (npm) Vendor— Affected before 0.45.3 Fixed in 0.45.3 Patch available GHSA-5888-ffcr-r425

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:blitzjs:blitz:*:*:*:*:*:node.js:*:*before 0.45.3Vulnerableblitz-js
cpe:2.3:a:blitzjs:superjson:*:*:*:*:*:node.js:*:*before 1.8.1Vulnerableblitz-js
  • cpe:2.3:a:blitzjs:blitz:*:*:*:*:*:node.js:*:* Versions before 0.45.3 Vulnerable ·blitz-js
  • cpe:2.3:a:blitzjs:superjson:*:*:*:*:*:node.js:*:* Versions before 1.8.1 Vulnerable ·blitz-js

Remediation

  • Fix · CNA superjson (blitz-js) Fixed in 1.8.0
  • Fix · GHSA-5888-ffcr-r425 superjson (npm) Fixed in 1.8.1 Advisory →
  • Fix · GHSA-5888-ffcr-r425 blitz (npm) Fixed in 0.45.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-23631
  2. 2026-10-03 Alias added: GHSA-5888-ffcr-r425

References

Sources